TcXaeMgmt.psm1

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
#
# Script module for module 'TcXaeMgmt'
#
Set-StrictMode -Version Latest

# Summary: PowerShellGet is supported on Windows PowerShell 5.1 or later and PowerShell 6.0+ / 7.0+

$isCore = ($PSVersionTable.Keys -contains "PSEdition") -and ($PSVersionTable.PSEdition -ne 'Desktop')
Write-Verbose "IsCore: $isCore"
$psVersion = $PSVersionTable.PSVersion
Write-Verbose "PSVersion: $psVersion"

if ($psVersion -ge [Version]'7.0')
{
     $script:Framework = 'netcoreapp3.1'
     $script:FrameworkToRemove = 'net461','netstandard2.0','net50'
} 
elseif ($psVersion -ge [Version]'6.0') 
{
    $script:Framework = 'netstandard2.0'
    $script:FrameworkToRemove = 'net461','netcoreapp3.1','net50'
}
else {
    $script:Framework = 'net461'
    $script:FrameworkToRemove = 'netstandard2.0','netcoreapp3.1','net50'
}

# Set up some helper variables to make it easier to work with the module
$script:PSModule = $ExecutionContext.SessionState.Module
$script:PSModuleRoot = $script:PSModule.ModuleBase
$script:PSMainAssembly = 'TwinCAT.Management.dll'

## CONSTRUCT A PATH TO THE CORRECT ASSEMBLY
$pathToAssembly = [io.path]::combine($PSScriptRoot, $script:Framework, $script:PSMainAssembly)
$pathToFramework = Join-Path -Path $script:PSModuleRoot -ChildPath $script:Framework
$pathToAssembly = Join-Path -Path $pathToFramework -ChildPath $script:PSMainAssembly

## Remove framework binaries that are not needed
#$FrameworkToRemovePath = Join-Path -Path $script:PSModuleRoot -ChildPath $script:FrameworkToRemove
#if (Test-Path $FrameworkToRemovePath)
#{
# Remove-Item $FrameworkToRemovePath -Force -Recurse
#}

# NOW LOAD THE APPROPRIATE ASSEMBLY
Write-Verbose "Loading assembly '$pathToAssembly'"
$importedModule = Import-Module -Name $pathToAssembly -PassThru