Functions/Authentication/New-PASSession.ps1

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
function New-PASSession {
    <#
.SYNOPSIS
Authenticates a user to CyberArk Vault.

.DESCRIPTION
Authenticates a user to a CyberArk Vault and returns a token and a webrequest session object
that can be used in subsequent PAS Web Services calls.
In addition, this method allows you to set a new password.
Authenticate using CyberArk, LDAP or RADIUS authentication (From CyberArk version 9.7 up).
For CyberArk version older than 9.7:
    Only CyberArk Authentication method is supported.
    newPassword Parameter is not supported.
    useRadiusAuthentication Parameter is not supported.
    connectionNumber Parameter is not supported.
Additionally, if using CyberArk 9.7+, this function will return version information from PVWA

.PARAMETER Credential
A Valid PSCredential object.

.PARAMETER UseV9API
Specify the UseV9API to send the authentication request via the v9 API endpoint.

.PARAMETER newPassword
Optional parameter, enables you to change a CyberArk users password.
Must be supplied as a SecureString (Not Plain Text).

.PARAMETER useRadiusAuthentication
Whether or not users will be authenticated via a RADIUS server.

.PARAMETER type
When using the version 10 API endpoint, specify the type of authentication to use.
Valid values are CyberArk, LDAP, Windows or RADIUS
Windows is only a valid option for version 10.4 onward.

.PARAMETER AdditionalInfo
The Version 10 API accepts a string value containing Additional Info

.PARAMETER SecureMode
The Version 10 API accepts a boolean value indicating true or false for SecureMode

.PARAMETER connectionNumber
In order to allow more than one connection for the same user simultaneously, each request
should be sent with different 'connectionNumber'.
Valid values: 1-100

.PARAMETER SkipVersionCheck
If the SkipVersionCheck switch is specified, Get-PASServer will not be called after
successfully authenticating. Get-PASServer is not supported before version 9.7.

.PARAMETER SessionVariable
After successful execution of this function, and authentication to the Vault, a WebSession
object, that contains information about the connection and the request, including cookies,
will be created and passed back in the return object.
This can be passed to subsequent requests to ensure websessions are persistant when the
PAS Web Service exists accross PVWA servers behind a load balancer.

.PARAMETER BaseURI
A string containing the base web address to send te request to.
Pass the portion the PVWA HTTP address.
Do not include "/PasswordVault/"

.PARAMETER PVWAAppName
The name of the CyberArk PVWA Virtual Directory.
Defaults to PasswordVault

.PARAMETER UseDefaultCredentials
See Invoke-WebRequest
Uses the credentials of the current user to send the web request

.EXAMPLE
Logon to Version 10 with LDAP credential and save auth token:

$token = New-PASSession -Credential $cred -BaseURI https://PVWA -type LDAP

.EXAMPLE
Logon to Version 10 with CyberArk credential:

New-PASSession -Credential $cred -BaseURI https://PVWA -type CyberArk

.EXAMPLE
Logon to Version 10 with Windows Integrated Authentication

New-PASSession -BaseURI https://PVWA -UseDefaultCredentials

.EXAMPLE
Logon to Version 9 with credential and save auth token:

$token = New-PASSession -Credential $cred -BaseURI https://PVWA -UseV9API

Request would be sent to PVWA URL https://PVWA/PasswordVault/

.EXAMPLE
Logon to Version 9 where PVWA Virtual Directory has non-default name:

New-PASSession -Credential $cred -BaseURI https://PVWA -PVWAAppName CustomVault -UseV9API

Request would be sent to PVWA URL https://PVWA/CustomVault/

.INPUTS
A PSCredential Object can be piped to this function.

.OUTPUTS
CyberArk Session token; This token identifies the session with the vault, and
is supplied to every other web service request in the same session.
A WebSession object; This contains information about the connection and the request,
including cookies. Can be supplied to other web service requests.
baseURI; this is the URL provided as an input to this function, it can be piped to
other functions from this return object.
ConnectionNumber; the connectionNumber provided to this function.
ExternalVersion; The External Version number retrieved from CyberArk.

Output uses defined default properties.
To force all output to be shown, pipe to Select-Object *

.NOTES

.LINK
#>

    [CmdletBinding(SupportsShouldProcess, DefaultParameterSetName = "v10")]
    param(
        [parameter(
            Mandatory = $true,
            ValueFromPipeline = $true,
            ParameterSetName = "v10"
        )]
        [parameter(
            Mandatory = $true,
            ValueFromPipeline = $true,
            ParameterSetName = "v9"
        )]
        [ValidateNotNullOrEmpty()]
        [PSCredential]$Credential,

        [parameter(
            Mandatory = $false,
            ValueFromPipelinebyPropertyName = $false,
            ParameterSetName = "v9"
        )]
        [switch]$UseV9API,

        [Parameter(
            Mandatory = $false,
            ValueFromPipeline = $false,
            ParameterSetName = "v10"
        )]
        [Parameter(
            Mandatory = $false,
            ValueFromPipeline = $false,
            ParameterSetName = "v9"
        )]
        [SecureString]$newPassword,

        [Parameter(
            Mandatory = $false,
            ValueFromPipeline = $false,
            ParameterSetName = "v9"
        )]
        [bool]$useRadiusAuthentication,

        [Parameter(
            Mandatory = $false,
            ValueFromPipeline = $false,
            ParameterSetName = "v10"
        )]
        [ValidateSet("CyberArk", "LDAP", "Windows", "RADIUS")]
        [string]$type = "CyberArk",

        [Parameter(
            Mandatory = $false,
            ValueFromPipeline = $false,
            ParameterSetName = "v10"
        )]
        [string]$AdditionalInfo,

        [Parameter(
            Mandatory = $false,
            ValueFromPipeline = $false,
            ParameterSetName = "v10"
        )]
        [bool]$SecureMode,

        [Parameter(
            Mandatory = $false,
            ValueFromPipeline = $false,
            ParameterSetName = "v9"
        )]
        [ValidateRange(1, 100)]
        [int]$connectionNumber,

        [Parameter(
            Mandatory = $false,
            ValueFromPipeline = $false
        )]
        [switch]$SkipVersionCheck,

        [parameter(
            Mandatory = $false,
            ValueFromPipeline = $false
        )]
        [string]$SessionVariable = "PASSession",

        [parameter(
            Mandatory = $true,
            ValueFromPipeline = $false
        )]
        [string]$BaseURI,

        [parameter(
            Mandatory = $false,
            ValueFromPipeline = $false
        )]
        [string]$PVWAAppName = "PasswordVault",

        [parameter(
            Mandatory = $false,
            ValueFromPipeline = $false,
            ParameterSetName = "integrated"
        )]
        [switch]$UseDefaultCredentials
    )

    BEGIN {

        #Construct URL for request
        if($($PSCmdlet.ParameterSetName) -eq "v10") {

            $URI = "$baseURI/$PVWAAppName/api/Auth/$type/Logon"

        } elseif($($PSCmdlet.ParameterSetName) -eq "integrated") {

            $URI = "$baseURI/$PVWAAppName/api/Auth/Windows/Logon"  #hardcode Windows for integrated auth

        } elseif($($PSCmdlet.ParameterSetName) -eq "v9") {

            $URI = "$baseURI/$PVWAAppName/WebServices/auth/Cyberark/CyberArkAuthenticationService.svc/Logon"

        }

    }#begin

    PROCESS {

        #Get request parameters
        $boundParameters = $PSBoundParameters | Get-PASParameter -ParametersToRemove Credential, UseV9API, SkipVersionCheck, UseDefaultCredentials

        If($PSBoundParameters.ContainsKey("Credential")) {

            #Add user name from credential object
            $boundParameters["username"] = $($Credential.UserName)
            #Add decoded password value from credential object
            $boundParameters["password"] = $($Credential.GetNetworkCredential().Password)

            $userDisplay = $boundParameters["username"]

        } ElseIf($PSBoundParameters.ContainsKey("UseDefaultCredentials")) {

            $userDisplay = "$env:USERDOMAIN\$env:USERNAME"

        }

        #deal with newPassword SecureString
        If($PSBoundParameters.ContainsKey("newPassword")) {

            #Include decoded password in request
            $boundParameters["newPassword"] = $(ConvertTo-InsecureString -SecureString $newPassword)

        }

        #Construct Request Body
        $body = $boundParameters | ConvertTo-Json

        if($PSCmdlet.ShouldProcess("$baseURI/$PVWAAppName", "Logon with User '$userDisplay'")) {

            #Send Logon Request
            $PASSession = Invoke-PASRestMethod -Uri $URI -Method POST -Body $Body -SessionVariable $SessionVariable -UseDefaultCredentials:($UseDefaultCredentials.IsPresent)

            #If Logon Result
            If($PASSession) {

                #Format Authentication token
                $SessionToken = @{"Authorization" = [string]$($PASSession.CyberArkLogonResult)}

                #WebSession Object
                $WebSession = $PASSession | Select-Object -ExpandProperty WebSession

                #Initial Value for Version variable
                [System.Version]$Version = "0.0"

                if( -not ($SkipVersionCheck)) {

                    Try {

                        #Get CyberArk ExternalVersion number, assign to Version variable.
                        [System.Version]$Version = Get-PASServer -sessionToken $SessionToken -WebSession $WebSession `
                            -BaseURI $BaseURI -PVWAAppName $PVWAAppName -ErrorAction Stop |
                            Select-Object -ExpandProperty ExternalVersion

                    } Catch {Write-Warning "Could Not Determine CyberArk Version"}

                }

                #Return Object
                [pscustomobject]@{

                    #Authentication Token - required for all subsequent Web Service Calls
                    "sessionToken"     = $SessionToken

                    #WebSession
                    "WebSession"       = $WebSession

                    #The Web Service URL the request was sent to
                    "BaseURI"          = $BaseURI

                    #PVWA Application Name/Virtual Directory
                    "PVWAAppName"      = $PVWAAppName

                    #The Connection Number
                    "ConnectionNumber" = $connectionNumber

                    #ExternalVersion
                    "ExternalVersion"  = $Version

                    #Set default properties to display in output
                } | Add-ObjectDetail -DefaultProperties sessionToken, BaseURI

            }

        }

    }#process

    END {}#end

}