Cisco.UCS.Common

3.0.0.10

PowerShell Module for Cisco Core (Core module in Cisco PowerTool Suite)

Minimum PowerShell version

5.1

Installation Options

Copy and Paste the following command to install this package using PowerShellGet More Info

Install-Module -Name Cisco.UCS.Common -RequiredVersion 3.0.0.10

You can deploy this package directly to Azure Automation. Note that deploying packages with dependencies will deploy all the dependencies to Azure Automation. Learn More

Manually download the .nupkg file to your system's default download location. Note that the file won't be unpacked, and won't include any dependencies. Learn More

Author(s)

Cisco Systems

Copyright

(c) 2019 Cisco Systems, Inc. All rights reserved.

Requires License Acceptance

View License.txt

Owners

Tags

UCSPowerTool CiscoUCSCmdlets PowerToolCmdlets Linux Windows MacOSX

Cmdlets

Add-UcsHardwareProfile Get-UcsPowerToolCommunity Get-UcsHclAdvisoryTypes Get-UcsOsVendor Get-UcsOperatingSystem Get-UcsPowerToolConfiguration Set-UcsPowerToolConfiguration Get-UcsPSSession Export-UcsPSSession Get-UcsSoftwareImageList Get-UcsSoftwareImage Get-UcsHardwareProfile Invoke-UcsHclUtility New-UcsHardwareProfile Remove-UcsHardwareProfile

PSEditions

Desktop

Dependencies

This module has no dependencies.

Release Notes

Cisco.UCS.Common.Cmdlets -Version 3.0.0.0
February 2020

Key Features in Release:
   UCS PowerTool module(s) are compatible with PowerShell version 5.1 and PowerShell Core version 6.1 or higher.

Release notes:
   Cisco UCS PowerTool Suite
   https://www.cisco.com/c/en/us/support/servers-unified-computing/ucs-management-partner-ecosystem-software/products-release-notes-list.html

   

Version History

Version Downloads Last updated
3.0.2.4 2,119 9/9/2021
3.0.1.2 11,768 11/18/2020
3.0.0.10 (current version) 3,803 7/3/2020