Install-RequiredModule

3.0.0

Parses a RequiredModules.psd1 listing modules and attempts to import those modules.
If it can't find the module in the PSModulePath, attempts to install it from PowerShellGet.

The RequiredModules list looks like this (uses nuget version range syntax):
@{
   "PowerShellGet" = "2.0.4"
   "Configuration" = "[1.3.1,2.0)"
   "Pester"        = "[4.4.2,4.7.0]"
}

https:/
Parses a RequiredModules.psd1 listing modules and attempts to import those modules.
If it can't find the module in the PSModulePath, attempts to install it from PowerShellGet.

The RequiredModules list looks like this (uses nuget version range syntax):
@{
   "PowerShellGet" = "2.0.4"
   "Configuration" = "[1.3.1,2.0)"
   "Pester"        = "[4.4.2,4.7.0]"
}

https://docs.microsoft.com/en-us/nuget/reference/package-versioning#version-ranges-and-wildcards

Installation Options

Copy and Paste the following command to install this package using PowerShellGet More Info

Install-Script -Name Install-RequiredModule -RequiredVersion 3.0.0

You can deploy this package directly to Azure Automation. Note that deploying packages with dependencies will deploy all the dependencies to Azure Automation. Learn More

Manually download the .nupkg file to your system's default download location. Note that the file won't be unpacked, and won't include any dependencies. Learn More

Author(s)

Joel 'Jaykul' Bennett

Copyright

Copyright 2019, Joel Bennett

Owners

Tags

Install Modules Development ModuleBuilder

Functions

GetModuleVersion FindModuleVersion ImportRequiredModulesFile InstallModuleVersion Install-RequiredModule

Dependencies

Release Notes

3.0.0 Add support for installing to a local tool path
Switch -SkipImport to -Import -- inverting the logic to NOT import by default
2.0.1 Squash mistaken "InstallError" message caused by Select-Object -First
Clean up output that was unexpected
2.0.0 Switch to NuGetVersion to support wildcards like 3.*
Improve the error messages around aborted or failed installs
1.0.1 Fix "Version '3.4.0' of module 'Pester' is already installed"
1.0.0 This is the first public release - it probably doesn't work right

Version History

Version Downloads Last updated
4.0.6 49,032 6/4/2019
4.0.5 45 5/15/2019
4.0.4 70 4/27/2019
4.0.3 9 4/27/2019
4.0.2 19 4/27/2019
4.0.1 9 4/27/2019
4.0.0 16 4/24/2019
3.0.0 (current version) 23 3/22/2019
2.0.1 10 3/21/2019
2.0.0 16 3/21/2019
1.0.1 9 3/21/2019
1.0.0 11 3/20/2019
Show less