Requirements

2.3.4

PowerShell framework for declaratively defining and idempotently imposing system configurations

Installation Options

Copy and Paste the following command to install this package using PowerShellGet More Info

Install-Module -Name Requirements -RequiredVersion 2.3.4

Copy and Paste the following command to install this package using Microsoft.PowerShell.PSResourceGet More Info

Install-PSResource -Name Requirements -Version 2.3.4

You can deploy this package directly to Azure Automation. Note that deploying packages with dependencies will deploy all the dependencies to Azure Automation. Learn More

Manually download the .nupkg file to your system's default download location. Note that the file won't be unpacked, and won't include any dependencies. Learn More

Owners

Copyright

(c) 2018 Microsoft Corporation. All rights reserved.

Package Details

Author(s)

  • Chris Kuech

Functions

Format-Checklist Format-Verbose Invoke-Requirement New-Requirement New-RequirementGroup Set-Requirement Test-Requirement

Dependencies

This module has no dependencies.

FileList

Version History

Version Downloads Last updated
2.3.6 5,710 3/12/2020
2.3.5 24 3/9/2020
2.3.4 (current version) 222 12/17/2019
2.3.3 162 11/27/2019
2.3.2 44 11/26/2019
2.3.1 63 11/20/2019
2.3.0 178,424 11/17/2019
2.2.7 519 9/24/2019
2.2.6 28 9/21/2019
2.2.5 30 9/20/2019
2.2.4 88 9/6/2019
2.2.3 129 7/28/2019
2.2.2 69 7/2/2019
2.2.1 16 7/2/2019
2.2 19 7/1/2019
2.1 29 6/27/2019
2.0 31 6/13/2019
1.1.0 206 2/14/2019
1.0 3,399 10/16/2018
Show more