Test-WannaCryVulnerability

2.2

Test for applicable patches to prevent the WannaCry malware.  Tests for SMB1 protocol and component.

Installation Options

Copy and Paste the following command to install this package using PowerShellGet More Info

Install-Script -Name Test-WannaCryVulnerability

You can deploy this package directly to Azure Automation. Note that deploying packages with dependencies will deploy all the dependencies to Azure Automation. Learn More

Manually download the .nupkg file to your system's default download location. Note that the file won't be unpacked, and won't include any dependencies. Learn More

Author(s)

Thomas J. Malkewitz @dotps1

Owners

Tags

dotps1 WannaCry WannaCrypt EternalBlue SMB1 Malware

Dependencies

This script has no dependencies.

Release Notes

Added LastBootUpTime to returned PSCustomObject per suggestion by Brett Miller (@BrettMiller_IT).

Version History

Version Downloads Last updated
2.2 (current version) 511 5/18/2017
2.1 53 5/17/2017
2.0 53 5/17/2017
1.4 62 5/16/2017
1.3 15 5/16/2017
1.2 9 5/16/2017
1.1 11 5/15/2017
1.0 12 5/15/2017