xCertificate

2.0.0.0

This module includes DSC resources that simplify administration of certificates on a Windows Server

Minimum PowerShell version

4.0

Installation Options

Copy and Paste the following command to install this package using PowerShellGet More Info

Install-Module -Name xCertificate -RequiredVersion 2.0.0.0

You can deploy this package directly to Azure Automation. Note that deploying packages with dependencies will deloy all the dependencies to Azure Automation. Learn More

Manually download the .nupkg file to your system's default download location. Note that the file won't be unpacked, and won't include any dependencies. Learn More

Author(s)

PowerShell DSC

Copyright

2015

Owners

Tags

DesiredStateConfiguration DSC DSCResourceKit DSCResource

DSCResources

xCertificateImport xCertReq xPfxImport

Dependencies

This module has no dependencies.

Release Notes

* Breaking Change - Updated xPfxImport Store parameter is now a key value making it mandatory
* Updated xPfxImport with new Ensure support
* Updated xPfxImport with support for the CurrentUser value
* Updated xPfxImport with validationset for the Store parameter
* Added new resource: xCertificateImport

Version History

Version Downloads Last updated
3.2.0.0 143,452 2/8/2018
3.1.0.0 6,183,478 12/20/2017
3.0.0.0 8,243 8/23/2017
2.8.0.0 17,307 7/12/2017
2.7.0.0 3,408 6/1/2017
2.6.0.0 2,765 5/31/2017
2.5.0.0 46,038 4/19/2017
2.4.0.0 14,162 3/8/2017
2.3.0.0 5,854 12/14/2016
2.2.0.0 2,864 11/2/2016
2.1.0.0 5,345 6/29/2016
2.0.0.0 (current version) 894 5/18/2016
1.1.0.0 3,025 12/3/2015
1.0.1.0 1,124 7/24/2015
1.0.0.0 98 6/17/2015
Show less