PowerLine

2.1.0

Classes for richer output and prompts

Minimum PowerShell version

5.0.0

Installation Options

Copy and Paste the following command to install this package using PowerShellGet More Info

Install-Module -Name PowerLine -RequiredVersion 2.1.0

You can deploy this package directly to Azure Automation. Note that deploying packages with dependencies will deloy all the dependencies to Azure Automation. Learn More

Manually download the .nupkg file to your system's default download location. Note that the file won't be unpacked, and won't include any dependencies. Learn More

Author(s)

Joel Bennett

Copyright

(c) 2016 Joel Bennett. All rights reserved.

Owners

Tags

Prompt ANSI VirtualTerminal

Functions

Get-Elapsed Get-ShortenedPath Test-Success Test-Elevation New-PowerLineBlock Set-PowerLinePrompt

Dependencies

This module has no dependencies.

Release Notes


       Add -UseAnsiEscapes switch for controlling the use of VT escape sequences (in preparation for adding a Write-Host adapter)
       Add pre-compiled assembly for .Net Core
       

Version History

Version Downloads Last updated
3.1.2 6,633 4/27/2019
3.1.1 177 4/14/2019
3.1.0 17 4/14/2019
3.0.3 4,278 10/21/2017
3.0.2 7 10/21/2017
3.0.1 4 10/21/2017
3.0.0 9 10/21/2017
2.3.1 1,103 5/12/2017
2.3.0 17 5/12/2017
2.1.0 (current version) 832 9/27/2016
2.0.0 56 9/12/2016
1.3.1 23 9/6/2016
1.3 .0 10 9/6/2016
1.0.0 27 9/1/2016
Show less